Cisco – Deploying OSPF for ISP (ospf)

a3-1up.pdf, read more

OSPF: Adding Networks
Method One
• redistribute connected subnets
Works for all connected interfaces on the router but sends
networks as external type-2s – which are not summarized
router ospf 100
redistribute connected subnets
• Do NOT do this!
Because:
Type-2 LSAs flood through entire network
These LSAs are not all useful for determining paths through
backbone; simply take up space

OSPF: Adding Networks
Method Two
• Specific network statements
Every active interface with a configured IP address needs an
OSPF network statement
Interface that will have no OSPF neighbours needs passiveinterface
to disable OSPF Hello’s
That is: all interfaces connecting to devices outside the ISP
backbone (i.e. customers, peers, etc)
router ospf 100
network 192.168.1.1 0.0.0.3 area 51
network 192.168.1.5 0.0.0.3 area 51
passive interface Serial 1/0

OSPF: Adding Networks
Method Three
• Network statements – wildcard mask
Every active interface with configured IP address covered by
wildcard mask used in OSPF network statement
Interfaces covered by wildcard mask but having no OSPF
neighbours need passive-interface (or use passive-interface
default and then activate the interfaces which will have OSPF
neighbours)
router ospf 100
network 192.168.1.0 0.0.0.255 area 51
passive-interface default
no passive interface POS 4/0

Don’t ever use Method 1
• Method 2 doesn’t scale too well when router has a
large number of interfaces but only a few with OSPF
neighbours
→ solution is to use Method 3 with “no passive” on interfaces
with OSPF neighbours
• Method 2 is fine for core/infrastructure routers
• Method 3 is preferred for aggregation routers
Or use iBGP next-hop-self
Or even ip unnumbered on external point-to-point links

OSPF: Adding Networks
Example One
Aggregation router with large number of leased line
customers and just two links to the core network:
interface loopback 0
ip address 192.168.255.1 255.255.255.255
interface POS 0/0
ip address 192.168.10.1 255.255.255.252
interface POS 1/0
ip address 192.168.10.5 255.255.255.252
interface serial 2/0:0 …
ip unnumbered loopback 0
! Customers connect here ^^^^^^^
router ospf 100
network 192.168.255.1 0.0.0.0 area 51
network 192.168.10.0 0.0.0.3 area 51
network 192.168.10.4 0.0.0.3 area 51
passive-interface default
no passive interface POS 0/0
no passive interface POS 1/0

This entry was posted in Cisco. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s