Cisco – Bidirectional Forwarding Detection (BFD)

 Improve the Convergence of Mission-Critical Networks with Bidirectional Forwarding Detection (BFD).

bfd slow-timers 3000
!
interface FastEthernet0/0
 bfd interval 100 min_rx 100 multiplier 3
 bfd echo

OSPF uses BFD on all interfaces
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0
 bfd all-interfaces

OSPF uses BFD on Fast Ethernet interface only
interface FastEthernet0/0
 ip address 10.0.0.5 255.255.255.0
 ip ospf bfd
 bfd interval 100 min_rx 100 multiplier 3

Using BFD with BGP
interface FastEthernet0/0
 ip address 10.0.0.5 255.255.255.0
 bfd interval 100 min_rx 100 multiplier 3
!
router bgp 65000
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.0.0.6 remote-as 65000
 neighbor 10.0.0.6 fall-over bfd
 neighbor 172.16.0.12 remote-as 65000
 neighbor 172.16.0.12 update-source Loopback0
 neighbor 172.16.0.12 fall-over bfd
 no auto-summary

a1#show ip ospf neighbor
Neighbor ID  Pri  State      Dead Time Address    Interface
172.16.0.21    0  FULL/  -   00:00:37  172.16.1.2 Serial0/0/0.100
172.16.0.12    1  FULL/BDR   00:00:31  10.0.0.6   FastEthernet0/0

a1#show bfd neighbor
OurAddr    NeighAddr  LD/RD  RH/RS  Holddown(mult)  State  Int
10.0.0.5   10.0.0.6    1/2    Up        0    (3 )   Up     Fa0/0

a1#show bfd neighbor

OurAddr    NeighAddr  LD/RD  RH/RS  Holddown(mult)  State  Int

10.0.0.5   10.0.0.6    1/2    Up        0    (3 )   Up     Fa0/0

BFD is used by OSPF and HSRP

a1#show bfd neighbors details
OurAddr    NeighAddr  LD/RD  RH/RS  Holddown(mult)  State  Int
10.0.0.5   10.0.0.6    1/2    Up        0    (3 )   Up     Fa0/0
Session state is UP and using echo function with 100 ms interval.
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 1000000, MinRxInt: 1000000, Multiplier: 3
Received MinRxInt: 1000000, Received Multiplier: 3
Holddown (hits): 0(0), Hello (hits): 1000(866)
Rx Count: 525, Rx Interval (ms) min/max/avg: 1/23596/923 last: 176 ms ago
Tx Count: 869, Tx Interval (ms) min/max/avg: 1/1000/869 last: 624 ms ago
Elapsed time watermarks: -1 0 (last: 0)
Registered protocols: OSPF HSRP
Uptime: 00:05:59
Last packet: Version: 1            - Diagnostic: 0
             State bit: Up         - Demand bit: 0
             Poll bit: 0           - Final bit: 0
             Multiplier: 3         - Length: 24
             My Discr.: 2          - Your Discr.: 1
             Min tx interval: 1000000    - Min rx interval: 1000000
             Min Echo interval: 100000
This entry was posted in Cisco. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s