PfR – Performance Routing

PfR:Technology Overview

Pfr-overview.png

 

 

Pfr-general.png

Pfr-learn.png

pfr master
 policy-rules MYMAP
 logging
 border 10.4.5.4 key-chain key1
  interface Ethernet0/0 internal 
  interface Ethernet0/1 external
 !
 border 10.4.5.5 key-chain key1
  interface Ethernet0/0 internal 
  interface Ethernet0/1 external
!
ip prefix-list BRANCH1 seq 5 permit 30.1.0.0/16
!
pfr-map MYMAP 10
 match ip address prefix-list BRANCH1
!

 

The following example shows the ability to define specific applications:

pfr master
 policy-rules MYMAP
 logging
 border 10.4.5.4 key-chain key1
  interface Ethernet0/0 internal 
  interface Ethernet0/1 external
 !
 border 10.4.5.5 key-chain key1
  interface Ethernet0/0 internal 
  interface Ethernet0/1 external
!
ip prefix-list FILTER_BRANCH1 seq 10 permit 10.1.1.0/24
ip prefix-list FILTER_BRANCH1 seq 20 permit 10.1.2.0/24
!
ip prefix-list FILTER_BRANCH2 seq 10 permit 10.1.3.0/24
ip prefix-list FILTER_BRANCH2 seq 20 permit 10.1.4.0/24
!
! Define FTP application
ip access-list extended MY_APP 10 
  permit ip any any eq 21
!
pfr-map MYMAP 10
  match traffic-class application telnet prefix-list FILTER_BRANCH1
  set mode select-exit good
  set delay threshold 2000
  set mode route control
  set mode monitor both
  no set resolve delay
  set active-probe echo 10.1.1.10
!
pfr-map MYMAP 20
  match traffic-class application http prefix-list FILTER_BRANCH2
  set mode select-exit good
  set delay threshold 2000
  set mode route control
  set mode monitor both
  no set resolve delay
!
pfr-map MYMAP 30
   traffic-class access-list MY_APP filter FILTER_BRANCH2
  set mode select-exit good
  set delay threshold 2000
  set mode route control
  set mode monitor both
  no set resolve delay
  set active-probe echo 10.1.3.10
!

 

Automatic Configuration

In this mode, Performance Routing (PfR) has to determine the traffic classes from the traffic flowing through the border routers. This is the “learn” block of the PfR configuration.

A very basic automatic learning configuration would be the following, where PfR automatically tracks the top talkers based on netflow information received from the BRs:

key chain key1
 key 1  
 key-string cisco
!
oer master
 logging
 border 10.4.5.4 key-chain key1
  interface Ethernet0/0 internal 
  interface Ethernet0/1 external
 !
 border 10.4.5.5 key-chain key1
  interface Ethernet0/0 internal 
  interface Ethernet0/1 external
 !
 learn
  throughput
  monitor 1
  periodic 0

learn-list
PfR supports a learn list configuration mode to simplify the learning of traffic classes and to provide greater flexibility. In each learn list, different criteria including prefixes, application definitions, filters, and aggregation parameters for learning traffic classes can be configured. A traffic class is automatically learned by PfR based on each learn list criteria, and each learn list is configured with a sequence number. The sequence number determines the order in which learn list criteria are applied. Learn lists allow different PfR policies to be applied to each learn list.

ip prefix-list BRANCH1 seq 5 permit 30.1.0.0/16
!
oer master
 max-range-utilization percent 10
 policy-rules MYMAP
 logging
 learn    
  throughput
  delay   
  periodic-interval 0
  monitor-period 1
  list seq 10 refname BRANCH_BUSINESS
   traffic-class application ssh filter BRANCH1
   throughput
  list seq 20 refname BRANCH_BE
   traffic-class prefix-list BRANCH1
   throughput
 holddown 180
 mode select-exit best
 periodic 180
!

Pfr-threshold2.png

 

 

This entry was posted in Cisco. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s