OpenNOP – Open Network Optimization Platform

OpenNOP – Open Network Optimization Platform.

!
hostname router1
!
interface FastEthernet0/0
 description to LAN
 ip address 10.1.1.1 255.255.255.0
 ip policy route-map Redirect
 no shutdown
 duplex auto
 speed auto
exit
!
interface Serial0/0
 description to WAN
 ip address 192.168.1.1 255.255.255.0
 ip policy route-map Redirect
 no shutdown
 no fair-queue
exit
!
interface FastEthernet0/1
 description to Accelerator
 ip address 172.16.1.1 255.255.255.0
 no shutdown
 duplex auto
 speed auto
exit
!
ip access-list extended RedirectedTraffic
 remark Route all TCP traffic to OpenNOP.
 deny ip any host 172.16.1.1
 deny ip any host 192.168.1.1
 deny ip any host 10.1.1.1
 permit tcp any any
exit
!
rtr 1
 type echo protocol ipicmpecho 172.16.1.2
exit
!
rtr schedule 1 life forever start-time now
!
track 1 rtr 1 reachability
!
route-map Redirect permit 1
 match ip address RedirectedTraffic
 set ip next-hop verify-availability 172.16.1.2 1 track 1
exit
!
ip route 172.16.2.0 255.255.255.0 192.168.1.2
!
end

!
hostname router2
!
interface FastEthernet0/0
 description to LAN
 ip address 10.1.2.1 255.255.255.0
 ip policy route-map Redirect
 no shutdown
 duplex auto
 speed auto
exit
!
interface Serial0/0
 description to WAN
 ip address 192.168.1.2 255.255.255.0
 ip policy route-map Redirect
 no shutdown
 no fair-queue
exit
! 
interface FastEthernet0/1
 description to Accelerator
 ip address 172.16.2.1 255.255.255.0
 no shutdown
 duplex auto
 speed auto
exit
!
ip access-list extended RedirectedTraffic
 remark Route all TCP traffic to OpenNOP.
 deny ip any host 172.16.2.1
 deny ip any host 192.168.1.2
 deny ip any host 10.1.2.1
 permit tcp any any
exit
!
rtr 1
 type echo protocol ipicmpecho 172.16.2.2
exit
!
rtr schedule 1 life forever start-time now
!
track 1 rtr 1 reachability
!
route-map Redirect permit 1
 match ip address RedirectedTraffic
 set ip next-hop verify-availability 172.16.2.2 1 track 1
exit
!
ip route 172.16.1.0 255.255.255.0 192.168.1.1
!
end
This entry was posted in Uncategorized. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s